Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2000-10-21 07:58:10


----- Original Message -----
From: "John Maddock" <John_Maddock_at_[hidden]>

> >>Anyhow, I'll press on with a defect report.
> >
> >But the result will almost certainly be that const int is a signed
> integral
> >type, and so forth.
>
> Maybe, it depends upon what you mean by integer: does "const int"
implement
> operator ++, or operator += ?
> Depending upon the context the answer is either yes or no, the only thing
> you can really say is that it is a cv-qualified integer.

Maybe, just for clarity, we should rename is_pointer(), is_noncv_pointer(),
etc. That way we don't tread on the putative intent of the standard (as we
are apparently doing now), and what we are doing is absolutely clear.

> Just to clarify, there is already a is_signed_integral template, in fact
> there are three closely related templates:
>
> is_standard_signed_integral: those signed integral types required by the
> standard.
> is_extension_signed_integral: addition builtin signed integral types (long
> long etc).
> is_signed_integral: The union of the above two.

What about user-defined integral types?

-Dave


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk