Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2000-11-07 12:00:13

----- Original Message -----
From: "Beman Dawes" <beman_at_[hidden]>

> My question then is, "What should be the form of boost public interface
> macro names?"
> My worry is that the all uppercase, prefixed by BOOST_ rule produces names
> ugly enough that programmers will shy away from using them. Is there
> another scheme that is less ugly, but still unlikely to produce name
> conflicts?
> For example, would this be better:
> static_assert_macro( a == b );
> test_assert_macro( c == d );
> test_verify_macro( e == f );
> or this:
> static_assert_macro_( a == b );
> test_assert_macro_( c == d );
> test_verify_macro_( e == f );
> Maybe I'm the only one that worries about public interface macro names,
> I'd like to someone else can come up with a better scheme before we commit
> ourselves to names that are likely to be around for many years.

There's a reason we stick to ALL_UPPERCASE and prefix with BOOST_ for macro
names: to avoid name conflicts by adhering to a common convention. If we
make the prescription in our coding guidelines but fail to follow that
prescription in our public interface macros, we are not only undermining the
convention but, IMO, arrogantly flaunting our ability to do so.


Boost list run by bdawes at, gregod at, cpdaniel at, john at