|
Boost : |
From: Jesse Jones (jejones_at_[hidden])
Date: 2000-11-07 16:01:51
> [snip]
>
> BOOST_STATIC_ASSERT( a == b );
> BOOST_TEST_ASSERT( c == d );
> BOOST_TEST_VERIFY( e == f );
>
>Let's assume those names do a good job of denoting the semantics, and talk
>about their lexical aspect.
>
>My question then is, "What should be the form of boost public interface
>macro names?"
>
>My worry is that the all uppercase, prefixed by BOOST_ rule produces names
>ugly enough that programmers will shy away from using them. Is there
>another scheme that is less ugly, but still unlikely to produce name
>conflicts?
I would prefer it if macros were all upper case. For consistency I'd also
make all the debugging functions upper case even if some of them are
implemented as functions.
BOOST_TEST_ASSERT is an awfully ugly name, but I think boost has to use
something like that to avoid conflicts with existing code. However clients
can always use the preprocessor to create a nicer alias. Not ideal, but
neither is the C proproccessor. :-)
-- Jesse
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk