Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2000-11-23 11:40:00


From: "William Kempf" <sirwillard_at_[hidden]>

> However, I still don't like the name "function_ptr" here ;). It's
> not a pointer (I wouldn't even consider it a smart pointer) and it's
> not a function. Just my own .02 on something no one else probably
> cares about :).

It is a function pointer; we may add an operator* that returns *this to make
you feel better. :-)

function_ptr2<R, A1, A2> is supposed to be a direct replacement for R (*)
(A1, A2)... Except that it can't resolve overloads like the built-in pointer
can.

--
Peter Dimov
Multi Media Ltd.

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk