Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2000-12-23 19:35:54


on 12/20/00 9:23 AM, David Abrahams at abrahams_at_[hidden] wrote:

[SNIP Aleksey's comment about having no consistent naming scheme]

> You're right. I have been trying to avoid bringing that conclusion out into
> the open for days now ;-)

>> Well, did I really clarified anything? ;)

> At least you clarified that we have a problem. What would be really clear
> would be a proposal for a consistent naming scheme. Looking at the names we
> currently have, what most have in common is that the templates "complete the
> concept" they're describing by filling in missing operators. I don't think
> it's a problem that we don't have standard Concepts for most of these
> things. We shouldn't be trying to define them here, either. Let's think in
> terms of "concepts" with a small "c". Here's the list of names I extracted
> from v15 of dlw_oprs, for reference (a few may be missing; I used automated
> seaarch/replace tools):

[SNIP list]

I used manual methods and got this list, as of version 17:
(The *'ed names have "1" and "2" versions, I think.)

less_than_comparable*
equality_comparable*
multipliable*
addable*
subtractable*
dividable*
modable*
xorable*
andable*
orable*

incrementable
decrementable

dereferenceable
indexable

left_shiftable*
right_shiftable*
idempotent
negatable

totally_comparable*
additive*
multiplicative*
integer_multiplicative*
arithmetic*
integer_arithmetic*
bitwise*
unit_steppable
shiftable*
bit_manipulative*

float_operators*
integer_operators*
bitwise_integer_operators*
input_iterator_operators
forward_iterator_operators
bidirectional_iterator_operators
random_access_iterator_operators

operators2
operators

forward_iterator_helper
bidirectional_iterator_helper
random_access_iterator_helper

-- 
Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT mac DOT com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk