Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2001-03-29 09:26:25

On Wed, 28 Mar 2001, David Abrahams wrote:
abraha> I think there are lots of semantic requirements missing, though. For

Indeed, on the todo list :)

abraha> I didn't think so. Now you have to say what it means. Also, should it be
abraha> called additive_identity(x)? Wouldn't it be more interesting to have
abraha> zero<X>()?

The reason I went with zero(x) instead of zero<X>() is that for a matrix
the returned zero-matrix object needs to know how big it is, which it
can get from another matrix x.

abraha> shouldn't identity be called "multiplicative_identity", also?

Probably, but ouch, that's a bummer to write out, especially compared
to the mathematical I (for identity matrix) or "eye" in matlab.


 Jeremy Siek www:
 Ph.D. Candidate email: jsiek_at_[hidden]
 Univ. of Notre Dame work phone: (219) 631-3906

Boost list run by bdawes at, gregod at, cpdaniel at, john at