Boost logo

Boost :

From: Jesse Jones (jesjones_at_[hidden])
Date: 2001-03-15 20:33:00

>----- Original Message -----
>From: "Beman Dawes" <bdawes_at_[hidden]>
>> >> 9) I think the code would be clearer if member data names were
>> >decorated
>> >> somehow, eg fCount, mCount, _count, etc. :-)
>> >
>> >Stylistic suggestion, typically not entertained by Boost
>> >submissions. However, I'm interested in this topic and wouldn't mind
>> >hearing what others have to say on this, even if it's in private e-
>> >mail.
>> Yes, it is stylistic so anything reasonable is acceptable. I've
>> become used to the _count style, and feel most programmers will understand
>> it right away when they see it. It fits well with the other naming
>> conventions we use. But each to his own...
>...and keeping in mind that names beginning with underscores are reserved to
>the implementation in the global namespace (

I'd prefer fCount or mCount to _count, but any of them will be better
than just count IMO. And Bill seems to avoid mixed case names so using a
leading underscore should be OK for him if it's used to signal a member
data name...

  -- Jesse

Boost list run by bdawes at, gregod at, cpdaniel at, john at