From: Beman Dawes (bdawes_at_[hidden])
Date: 2001-04-06 11:00:26
At 11:50 AM 3/26/2001, williamkempf_at_[hidden] wrote:
>--- In boost_at_y..., Jens Maurer <Jens.Maurer_at_g...> wrote:
>> - fast_mutex strikes me as a bad name. We just killed fast_crc.
>> What about "unchecked"?
>There's a lot more to the design of fast_mutex than just it's
>unchecked locking policy (see my comments on speed below). I'm not
>against renaming here, however. Maybe simple_mutex? (I don't like
>that either, but...)
How about basic_mutex?
In any case, I think (at least half seriously) we should ban "fast" in
names. It is like waving a red flag in front of a bull. Someone almost
always comes up with a case where some other approach is faster, and that
starts a discussion that ends up with the name being changed.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk