From: David Abrahams (abrahams_at_[hidden])
Date: 2001-05-18 08:47:22
----- Original Message -----
From: "Daryle Walker" <darylew_at_[hidden]>
Sent: Thursday, May 17, 2001 9:20 AM
Subject: [boost] Re: What about "dlw_oprs.zip" and "dlw_util.zip"?
> on 5/16/01 7:51 AM, Aleksey Gurtovoy at alexy_at_[hidden] wrote:
> > David Abrahams wrote:
> >> Before I look at dlw_oprs.zip I'd like to hear from Aleksey that his
> >> concerns have been addressed.
> > They were, except the 'identity_querible' name, with which I am still
> > uncomfortable. Actually, isn't the unary plus operator a part of
> > (one-argument) 'addable' concept? IMO, expressions like +a don't make
> > sense if you can't also write a1 + a2 and a1 += a2, and, on the other
> > if the latter two are allowed, is there a reason for not providing also
> > +a form? As for me, right now I can't think of one.. so we might have a
> > chance to make the library more consistent and get rid of the
> > name at the same time :).
> I like the name :). We don't need 100% agreement, do we?
At this point, we do. If you want your contribution to be integrated, you
have to reduce the amount of time I waste thinking about the merits of
little tweaks. Just stick with the uncontroversial and well-understood
changes. We can all agree that most of what you've done is an improvement.
If reaching absolute agreement means not adding some pet features, it's
worth it. If we consider each potential addition separately from the
uncontroversial stuff, the overall benefits and progress will be greater.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk