Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2001-05-18 11:51:17

----- Original Message -----
From: "Gary Powell" <Gary.Powell_at_[hidden]>
> I have mixed thoughts about this next suggestion, and that is to
> a member function "swap" and a specialization in the namespace "std" of
> swap. Partly because I'm not sure that for the types, float, etc it really
> makes much difference, and partly because for a user defined type there
> already a host of issues with std::swap etc. (there is plenty of previous
> discussion and I don't really want to restart that.)

And there are active issues in the core and library working groups of the
standards committee on this topic. See (lib 225) (lib 229) (core 229)


Boost list run by bdawes at, gregod at, cpdaniel at, john at