Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2001-05-22 14:42:44

At 02:37 PM 5/22/2001, Vesa Karvonen wrote:

>"Aleksey Gurtovoy" <alexy_at_[hidden]>:
>> So I am all in favor of the new technique!
>I like it too.
>> There is one issue with the library that I personally would like to
>> see resolved at this stage, though: names of the macros. IMO, now they
>> are too short and too generic for macro names, even with the BOOST_
>> prefix. I understand that longer names could cause some portability
>> problems, but still I would prefer to see something less general/more
>> long in place of BOOST_IF, BOOST_INC or BOOST_DEC. At least the
>> library name, or some other indication of scope of these macros should
>> be added, e.g. as I did it in the above example (BOOST_PREPROCESSOR_IF,
>All of the library, including naming, is obviously tentative at this
>I would personally prefer a somewhat shorter prefix like CPP, which is
>name I also had in mind for the library, but I can live with PREPROCESSOR
>if that is the consensus.

Pending killer arguments from others, I [slightly] prefer the CPP names,
although I could certainly live with PREPROCESSOR. But I do agree with
Alexsey that just plain BOOST_IF, etc, is a bit too generic.


Boost list run by bdawes at, gregod at, cpdaniel at, john at