Boost logo

Boost :

From: Vesa Karvonen (vesa.karvonen_at_[hidden])
Date: 2001-05-23 05:43:42

"John (EBo) David":
> I agree. BOOST_IF... seems way to general, but adding _CPP_ to the name
> may throw a few newcomers a bit because of the historical use of CPP to
> mean "C++" and not the preprocessor. Coming up with a good naming
> convention for this one is likely to be difficult...

Personally, I don't mind newcomers to be slightly confused with the naming,
because I don't expect the CPP library being used except in rather advanced
library code. The CPP name is, after all, a pun, so I know that it is a bit
ambiquous. Anyway, I think that the scale is pointing towards PREPROCESSOR,
so I'll change to that.

Here is my TBD list for the library:
- Change library name/prefix to PREPROCESSOR
- Design a unit test for the library
- Improve the header generator:
  - parameterize by the recursion depth limits and prefixes
  - make it generate the unit test
- Update and convert documents to HMTL
- Review everything

If there are more requests or proposals for the library, now would be a good
time to tell about them.

After that I think that there isn't much to be gained by continuing to
refine the library at this stage, so I think that it would be about ready
for formal reviewing.

Boost list run by bdawes at, gregod at, cpdaniel at, john at