Boost logo

Boost :

From: joel de guzman (joel_at_[hidden])
Date: 2001-05-23 09:16:18

From: "David Abrahams" wrote:

> One nit: people want "_" for /so/ many things in C++... I am leery of
> reserving it for any one use (and it gets to be pretty useless when
> namespaces are involved: "boost::_"). So please consider using a default
> argument of -1 to mean forever.

OK gotya. But -1 still doesn't feel right. I prefer your defaults:

repeat<0>(a); // zero or more
repeat<1>(a); // one or more
repeat<0, 1>(a); // zero or one
repeat<8, 8>(a); // exactly 8 (a bit awkward but will do)

repeat? loop? iterate?

Hey how about variable repeats? I encounter many times
when parsing files and streams that the size of *something* is
prefix encoded. Example:

   iterate(string_length){ char }

Joel de Guzman

Boost list run by bdawes at, gregod at, cpdaniel at, john at