Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2001-05-25 12:53:28

on 5/23/01 10:22 PM, Hubert HOLIN at Hubert.Holin_at_[hidden] wrote:

> Paris (U.E.), le 24/05/2001

> I have just uploaded an updated version at
> 1) "special_functions.hpp" now simply includes the content of the files
> in the (new) folder "special_functions". Thus each function (which may
> come in various flavours) has its own header, for greater modularity if
> wished.

I don't think "special_functions" is a good name. Relative to other math
stuff, atanh, sinc_pi, and sinhc_pi aren't that special. There can be
special functions in other areas besides math. So the name is ambiguous in
two ways. I've read suggestions here before to start dividing the Boost
files into sub-domains, before the main header and library subdirectories
get too large. Maybe it can start here, with a structure like:

    + quaternion.hpp
    + octonion.hpp
    + trigonmetric.hpp (sinc_pi, future stuff)
    + hyperbolic.hpp (atanh, sinhc_pi, future stuff)
    + rational.hpp (moved from parent directory)

    + random.hpp (moved from parent directory)
    + random/*.hpp (moved from parent directory)
    + crc.hpp (moved from parent directory)

With mirrored changes in the BOOST_ROOT/libs subdirectory.

Even if we don't go on this route, as the creator and sole user of
"special_functions.hpp", you don't need to keep it around for legacy reasons
after making it unnecessary.

Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT mac DOT com

Boost list run by bdawes at, gregod at, cpdaniel at, john at