Boost logo

Boost :

From: John Max Skaller (skaller_at_[hidden])
Date: 2001-06-18 11:44:34


David Abrahams wrote:

> 2. Ordering of class members: it really helps readability to have public
> members declared first, whenever possible. If you don't like starting your
> class with an access specifier, you can always use "struct" ;-)
>
> 3. Mixing of interface and implementation: it can really help readability to
> separate member function implementations from their declarations whenever
> possible

        FYI: I do not find this at all. On the contrary,
I really like all small functions to be defined 'in class',
and I like the data members defined first, so that I have
an idea what the representation is, and therefore be able to
understand the implementation of those functions that
are defined 'in class'. [Just my opinion]

        This style saves lots of useless comments
saying what a function does: the comments are
reserved for cases where the function is too
long to display in class.

-- 
John (Max) Skaller, mailto:skaller_at_[hidden]
10/1 Toxteth Rd Glebe NSW 2037 Australia voice: 61-2-9660-0850
checkout Vyper http://Vyper.sourceforge.net
download Interscript http://Interscript.sourceforge.net

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk