Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2001-06-27 13:09:10

I like the idea of providing two layers, 1) the basic thread_id and
lightweight API wrappers and 2) thread managers. This addresses Beman's
concern about people writing their own wrappers... because instead boost
will provide a standard wrapper (or set of wrappers) in layer 2). In
addition, layer 1) provides the flexibility that is needed in usage
scenarios that don't match those provided by layer 2).

I'd prefer the lightweight API's to be free functions in namespace thread,
not static. I function scopes I like the option of "using" to shorten

I like "thread_id" a lot as a name for the opaque thread handle.


On Thu, 28 Jun 2001, John Max Skaller wrote:
> class thread_api
> // lighweight API wrapper
> // purpose: platform independence
> class posix_api : public thread_api
> // posix extension
> class win32_api: public thread_api
> // win32 extension: boost only
> class thread_id
> // copyable thread id wrapper
> class my_favourite_thread_manager
> // design competetion on boost to choose
> // one or more alternatives

 Jeremy Siek www:
 Ph.D. Candidate, IU B'ton email: jsiek_at_[hidden]
 Summer Manager, AT&T Research phone: (973) 360-8185

Boost list run by bdawes at, gregod at, cpdaniel at, john at