Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-07-22 20:24:29

----- Original Message -----
From: "Vesa Karvonen" <vesa.karvonen_at_[hidden]>
> > <snip tall skinny code with approx. one identifier per line, names like
> > "out_ite", and no comments>
> ;-)
> It is not the amount of lines of code or how many identifier per line you
> that counts. What counts is that logic is not duplicated and code
> is easy.

, but
  seeing the
  when it
  up that

> > Hmm, the above comment says it all. I didn't understand your code. Maybe
> > could try again with a more conventional formatting style?
> I've underlined the bugs I've noticed so far. I also changed template type
> parameters to mixed case. Technically, the transform_adapter<> should be
> declared before using it in transform(), but I think that the code is
> to understand like this.

Thanks for the update, it is a bit easier to read.


Boost list run by bdawes at, gregod at, cpdaniel at, john at