Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2001-08-06 23:48:24

I reviewed the documentation and code, but did not test it.

I have no comments on the code itself that haven't already been covered,
except to revisit the naming of the "ron_" member variable. This led me to
the question "what is a good name for this variable?" Any choice has to be
generic enough to name any possible member variable, but because of this
genericity it is impossible for the name to communicate any meaning to the
user. So how does one write readable code using this idiom? Accessor/mutator
methods can be used for clarity, but this desugaring seems to overshadow the
benefits of using the library vs. manually coding the idiom. Using the
library saves a small amount of typing up front (the creation of a class
containing a single member), but it requires more typing overall to preserve
the readability of code using this member.

Without the ability for a user to specify the name of the data member (which
would require either macro tricks or a core language change), I think that
this particular idiom does not lend itself well to being translated into a
reusable, generic library.

Overall, my view is that this library should not be accepted into Boost.


Boost list run by bdawes at, gregod at, cpdaniel at, john at