Boost logo

Boost :

From: Ed Brey (edbrey_at_[hidden])
Date: 2001-08-09 11:19:41

From: <williamkempf_at_[hidden]>
> To make things clear, I see no real problem with using the
> name "wait" instead (or any other name). The name "join" was chosen
> because it's a well known technical term (and not just in POSIX).

Choosing a well-known name is a good starting point, but should only be
weighted so heavily, especially, if the name is not known universally
(stronger than well-known). In this case, there is one or more other
well-known industry terms, another being wait (otherwise, Win32
"WaitFor..." and Bourne shell "wait" wouldn't be named what they are). In
general, the most important consideration is that the common English
meaning correlates to the semantics, given a simple frame of reference.
The trouble with join is that to make the English fit, you need to
visualize the threads as a graph (or equivalent), with the join command
creating a vertex of n + 1 in-edges and 1 out-edge, where n is the number
of other threads being joined. This seems a bit heavy-weight for everyday

Boost list run by bdawes at, gregod at, cpdaniel at, john at