Boost logo

Boost :

From: John Maddock (John_Maddock_at_[hidden])
Date: 2001-08-11 06:41:10


>The C portion of MSL has the header <unistd.h>, so we could define
>BOOST_HAS_UNISTD_H inside the __MSL__ check in msl.hpp alongside. But I
>don't know if it has the things in <unistd.h> that we care about for
Boost.

OK done, the point being that we may want to check for more POSIX feature
checks in future...

>The version of the Metrowerks compiler that I have here on my desk
>(__MWERKS__ == 0x2401) passes the weak function template ordering test. So

>either we shouldn't be defining BOOST_WEAK_FUNCTION_TEMPLATE_ORDERING for
>this version of the compiler, or the test doesn't test thoroughly enough
>to detect what the compiler is getting wrong.

Hmm, the macro is still in the old config.hpp, but no longer appears to be
used by the function library. I was planning to use this in place of
BOOST_RE_NO_PARTIAL_FUNC_SPEC in the regex library - the tests need
updating to reflect the test cases used here but the issue (can't handle
tricky overloads involving partial ordering) is the same. I've demoted the
define in the metrowerks compiler config to 5.3 versions and less for now.

>Also, I couldn't find any code in Boost cvs that uses
>BOOST_WEAK_FUNCTION_TEMPLATE_ORDERING or uses BOOST_HAS_UNISTD_H directly.

At present BOOST_HAS_UNISTD_H is only used within the config system -
however the pool library currently includes <unistd.h> and should probably
be updated to use either BOOST_HAS_UNISTD_H or probably BOOST_HAS_PTHREADS
directly.

>The comment "If no cv-qualified specializations are allowed, then neither
>are cv-void ones" is backwards. It should say "are not allowed".

yep.

>The comment "We can't have a <cwchar> if there is no <cwchar>" should say
>"We can't have a <cwctype> [...]".

yep, thanks.

>Another typo: "If their is" instead of "If there is" (at least two places)

Yikes, thanks.

>Typo: "deduced form it".

Got it.

>Typo: "specialistion", spell it "specialization" (Besides the typo, I
>suggest we use the US spelling in the comments since we use it in the
>macro names.)

OK.

>It should just be "subset", not "sub-set".

OK

Thanks for the feedback!

- John Maddock
http://ourworld.compuserve.com/homepages/john_maddock/


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk