Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2001-08-15 11:12:03

From: "John Max Skaller" <skaller_at_[hidden]>
> Peter Dimov wrote:
> > * I (to express a non-field-expert view) don't have the slightest idea
> > "joining a thread" means; I think that when a function waits for a
thread to
> > finish, it should be called "waitForThreadToFinish", not "join."
> I agree, but aren't you prepared to learn a few new terms?

I am. It's not about whether I'm prepared to learn new terminology or not. I
was trying to say that I usually prefer code that is readable by non-experts
over code that uses a specific terminology that is not widely understood.

If you like I can put my other hat on and argue that condition::notify_one()
and condition::notify_all() should be 'signal' and 'broadcast',
respectively. My boat and all that.

Peter Dimov
Multi Media Ltd.

Boost list run by bdawes at, gregod at, cpdaniel at, john at