Boost logo

Boost :

From: Greg Colvin (gcolvin_at_[hidden])
Date: 2001-08-17 18:14:09

From: "Mark Rodgers" <mark.rodgers_at_[hidden]>
> > Wouldn't std::mem_fun be a different function that boost::mem_fun?
> Yes.
> > If so, where is the conflict?
> There is already boost::mem_fun in functional.hpp. Peter is proposing
> another boost::mem_fun.

Aha. I was think the conflict was with the standard library.

It does seem wrong to have to functions with the same name in
the same namespace. Is there anyway to unify these headers
so that there is only one boost::mem_fun?

Boost list run by bdawes at, gregod at, cpdaniel at, john at