Boost logo

Boost :

From: Mark Rodgers (mark.rodgers_at_[hidden])
Date: 2001-08-18 14:50:02

> * Optionally, I can make mem_fun rename-able (via #define BOOST_MEM_FUN
> something) for users that insist on using everything at once, although I
> don't think that would be necessary.

Or you could just rename it anyway so there is no conflict and we don't
have to worry. Jens suggested member_fun.
> Isn't it ironic that my earlier expression.hpp library used 'apply'
> instead of 'bind' for this operation? Now I'm convinced that 'bind' is a
> better name overall (all uses taken into account.)

I think you got it right first time.


Boost list run by bdawes at, gregod at, cpdaniel at, john at