Boost logo

Boost :

From: Vesa Karvonen (vesa.karvonen_at_[hidden])
Date: 2001-08-29 15:18:19


From: "Vesa Karvonen" <vesa.karvonen_at_[hidden]>
[...]
> I think that 'variant', 'optional', 'any' and smart pointers all have
> similarities but also significant intentional differences.
[...]
> I think that all of the above concepts should be further refined. For
> instance:
> - 'any' could probably make use of the 'vswitch' syntax.
> - 'variant<T,void>' seems very close to 'optional<T>'.
> - 'variant' and 'any' might or might not make use of some pointer syntax.

Or perhaps 'optional' could make use of 'any' and/or 'variant' syntax.

BTW: I find 'empty' a really bad name for a query function. It should be
'is_empty' to avoid unnecessary confusion. (Practically) Every C++ programmer
I know has at some point confused 'empty' with 'clear'. In my opinion,
following the bad naming of the standard library has very little merit. I'd
estimate that the cost of using 'empty' in the standard may have easily cost
hundreds of thousands of dollars worth of debugging time.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk