From: Beman Dawes (bdawes_at_[hidden])
Date: 2001-08-31 10:07:58
At 10:50 AM 8/28/2001, Darin Adler wrote:
>On Tuesday, August 28, 2001, at 04:06 AM, Peter Dimov wrote:
>> This is a more interesting statement. What is the negative impact of
>>> Adding it as boost::mem_fn would be very much my third choice.
>> This is rapidly becoming my first choice. Trying to call it mem_fun was
>> mistake (from a political if not technical point of view.)
>I personally think it's bad design to have three similar, but subtly
>different, function templates named std::mem_fun, boost::mem_fun, and
>boost::mem_fn. Why make programming even more subtle than it has to be by
>using names that look almost the same?
I second that.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk