Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-09-24 16:17:42

----- Original Message -----
From: "Peter Dimov" <pdimov_at_[hidden]>

<all of your good arguments snipped>

> Another perspective: we have three categories of users:
> 1. Threading experts;
> 2. Pthread programmers;
> 3. Programmers with little or no thread experience.
> The problem we're trying to solve, AFAICS, is that the current design does
> not target (3). The proposed solutions so far concentrate on renaming
> functions. Does this help?
> Not much, I'd say. We need another, higher level, abstraction layer that
> specifically designed with (3) in mind. Let's leave the current low-level
> design suitable for (1) and (2). Using standard POSIX names (and
> is such a step.

Okay, I'm convinced. ;-)

But one last lingering drop of resistance remains... whatever else we do,
wait() still feels wrong as a member function of condition.


Boost list run by bdawes at, gregod at, cpdaniel at, john at