Boost logo

Boost :

From: Scott McCaskill (scott_at_[hidden])
Date: 2001-09-25 12:13:52

> I think that intuitive names imply intuitive semantics. Notify_one and
> notify_all are, IMO, intuitive names. Are the semantics of those functions
> equally intuitive?

If one does not understand the semantics of those functions, then how could
any names be intuitive? OTOH, once one does understand what it means to
"notify a condition", notify_one and notify_all are excellent mnemonics.
That is the point--for the names to be mnemonic, not for the names to
attempt to serve as a substitute for documentation.

> Religious issue? Then why not use POSIX as a tie breaker?

I agree with what Ed had to say about why POSIX is not an ideal source of
names for a boost library. So yes, the POSIX background is the best
argument in favor of signal/broadcast, but 'best' != 'strong'.

Scott McCaskill

Boost list run by bdawes at, gregod at, cpdaniel at, john at