Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2001-09-25 19:35:45

At 01:28 PM 9/25/2001, David Abrahams wrote:

>Your changes look uniformly like improvements, especially the many HTML
>documentation improvements (wording got more concise, consistent and
>cleaner) and fixes you supplied for code examples (thanks! and curse that
>& symbol!)
>... except that you changed the names of the class templates. I was hapy
>with bidirectional_iterator_operators, but "bidirectional_iteratible"
>doesn't work at all for me. I'm not sure if "iteratible" is a word, but
>it is, I think it would be spelled "iteratable". In any case, I'd like to
>hear from others about the choice of names. Jeremy? Aleksey?

Historical note: I was the one who proposed the standard's
CopyConstructible requirement in 20.1.3. I've regretted a number of times
afterwards that I didn't spell it CopyConstructable.


Boost list run by bdawes at, gregod at, cpdaniel at, john at