Boost logo

Boost :

From: Aleksey Gurtovoy (alexy_at_[hidden])
Date: 2001-09-26 06:12:58

David Abrahams wrote:
> I was hapy with bidirectional_iterator_operators, but
> "bidirectional_iteratible" doesn't work at all for me.

Apparently, '[...]_iterator_operators' names (that I like too) don't fit
well into the general naming convention used through the rest of the library
(that is documented in our "Summary of Template Semantics"; in particular,
item 2 of that section says: "The name of an operator class template
indicates the /concept/ that its target class will model").

> I'm not sure if "iteratible" is a word, but if it is, I think
> it would be spelled "iteratable". In any case, I'd like to
> hear from others about the choice of names. Jeremy?
> Aleksey?

IMO if you think about "[input,output,..]_iteratable" as a name of the
concept, it becomes an acceptable choice. At least I am ok with it. FWIW,
Google search on "iteratable" finds ~70 distinct pages where the word is
used, mostly in CS texts, and at least one seemed to talk about higher
mathematics :).


Boost list run by bdawes at, gregod at, cpdaniel at, john at