Boost logo

Boost :

From: Robin (darkaurora_at_[hidden])
Date: 2001-09-27 22:00:53

--- In boost_at_y..., Daryle Walker <darylew_at_m...> wrote:
> But then it wouldn't look like the other C++ casts.

Then maybe name it as lexical_convert or something?

The functionality of lexical_cast is useful especially when
retrieving user input either through command line (argv) or some
other means.

Throwing a bad_lexcial_cast exception is clusmy when the program
needs to report exactly which input the user entered incorrectly. A
return value would be more appropriate so specific error can be
reported, no?

PS. I am very lousy at naming functions. I often have to fire up
MSword and use the synonym feature for naming my functions.

Boost list run by bdawes at, gregod at, cpdaniel at, john at