Boost logo

Boost :

From: Ed Brey (edbrey_at_[hidden])
Date: 2001-10-30 12:44:49

From: "James Curran/MVP" <jamescurran_at_[hidden]>
> Further, I'd prefer full words with no abbreviations. The
> rationale for this is that while there are many ways to abbreviate a
> word, there is only one way of spelling it right. ("Is 'squareroot'
> misspelled as 'sqrt' or 'sqroot' or 'sqr'?") C was intended to be terse
> & easy to type. C++ tries to be explicit and easy to read
> (reinterpret_cast?)

I guess verbosity doesn't help with spelling after all. I spell x^(1/2) as square_root.

However, it does help with readability, so that a reader who has to deal with lots of code finds fewer snippets of code with unknown meaning. Note that verbosity isn't always a requirement for readability, however. For example, auto_ptr would not be any better as auto_pointer. I'd say that the same applies to sqrt. It's good to use verbose names as a starting point, but then occasionally cut some down a bit for practicality so long as readability is not compromised.

Boost list run by bdawes at, gregod at, cpdaniel at, john at