Boost logo

Boost :

From: Lucas Ackerman (ackerman_at_[hidden])
Date: 2001-11-20 12:58:44

I'm trying to build the Boost libraries for use of the shared_ptr and
tuple classes and am having a really terrible time at it. I've read
every recent post on build problems re boost & jam, and even messed with
the source a bit in hopes of finding any obvious problems. my system is
Linux 2.2.19, Debian 2.2 (all from potato, except for qt2, and kdevelop
from the unstable branch), gcc version 2.95.4 (gcc-3.0 ver 3.0.2 is also
installed, though it seems to make no difference and I don't know how to
specify for jam to use it instead). These problems are the same for
boost 1.25.1 and the latest CVS, iirc, but my output here will be from
1.25.1 for consitency's sake.

Having failed at building the included ftjam via make and via classic
perforce jam, I got FTjam 2.3.5 from sourceforge (which reports itself
as v2.3.2), file ftjam-2.3.5-linux-libc6.tar.gz, since others here have
reported using it successfully. FTjam won't build Boost itself, as it
appears there is some missing functionality. this is the output it gives:

jam -ftools/build/allyourbase.jam -sTOOLS=gcc
tools/build/allyourbase.jam: line 1608: syntax error at keyword (
don't know how to make all
...found 1 target...
...can't find 1 target...

So, I of course need to build the Boost jam, which again bombs. in
tools/build/jam_src :

Link bin.linuxx86/jam
bin.linuxx86/jam.o: In function `main':
bin.linuxx86/jam.o(.text+0x25e): undefined reference to `yydebug'
collect2: ld returned 1 exit status

cc -o bin.linuxx86/jam bin.linuxx86/jam.o bin.linuxx86/jambase.o

...failed Link bin.linuxx86/jam ...
...failed updating 1 target...

I tried commenting out the 2 lines in jam.c where yydebug is used on the
presumption that I won't be trying to debug it, which allows the build
to complete correctly, but gives an infinite loop of the following when
trying to build Boost (where jamtest is my edited build):

jamtest -ftools/build/allyourbase.jam -sTOOLS=gcc
new-split.jam: No such file or directory
warning: unknown rule split
warning: unknown rule split
[ repeat until segfault ]

I'd really like to be coding with Boost, but am at a complete loss as
far as getting it built. I've tried every recent version of build
instructions found on this list archive, and also tried versions back to
1.24.0 (the earliest afaik containing tuple), which fails on 44
targets. The most common jam message I seem to get is "...found 7
targets..." alone.

Any help would be much appreciated. thanks,


Boost list run by bdawes at, gregod at, cpdaniel at, john at