Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-27 18:51:51

> Factionalism, I believe, is the last thing that we need here. That's why I
> hope to integrate Loki with boost, and I think that would add a lot of
> to boost. I suggest that some of Loki's facilities keep their current name
> unless an obviously better name comes up, because Loki's names are widely
> publicized and already in use. I'd be glad to use facilities in boost that
> are better designed than those in Loki (such as type_traits). I also agree
> to integrate with code in boost that was copied from Loki (initially
> acknowledgement, for which I had to ask), though I can't stop myself from
> noticing the irony. But I don't find it reasonable to port Loki to a
> typelist facility of which design I don't agree with.

It may in fact be that there's nothing to be gained from collaboration here.
Nonetheless my impression is that you have reacted with such antagonism to
mpl's complexity that you have not been able to think carefully about what
could be learned/used from it. I would still like to see you engage in a
productive conversation about that. Boost, like the C++ standards committee,
runs on consensus, and a demonstration of cooperativeness will go a long way
towards making people comfortable with your design. Typically, when people
see the opposite, the reaction is inaction - some will be engaged in a
stalemate, and others simply won't want to get involved.


Boost list run by bdawes at, gregod at, cpdaniel at, john at