Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-28 14:55:59

FWIW, I'm back to liking int_wrapper and type_wrapper ;-/.

On Wednesday, November 28, 2001, at 02:27 PM, Kevin Cline wrote:

> Andrei Alexandrescu writes:
>> From: "David Abrahams" <david.abrahams_at_[hidden]>
>>> They're only aliases if you look at them as types. I'm looking at
>>> them as
>>> metafunctions. They are identity metafunctions which return the same
>>> type/value which has been passed to them.
>> None of type2type nor int2type have the identity function as their
>> main use.
>> (After all, identity is hardly an interesting function). Their main
>> use is
>> to convert, as their name says, a type to a type and an integer to a
>> type,
>> respectively. See
> FWIW, I like the original names too. "int2type" is perfectly clear;
> "type2type" is perhaps not as obvious, but it's a better name than
> anything else proposed so far.
> --
> Kevin Cline
> Info: Unsubscribe: <mailto:boost-
> unsubscribe_at_[hidden]>
> Your use of Yahoo! Groups is subject to

Boost list run by bdawes at, gregod at, cpdaniel at, john at