Boost logo

Boost :

From: David A. Greene (greened_at_[hidden])
Date: 2001-11-28 17:05:58

Kevin Cline wrote:

> FWIW, I like the original names too. "int2type" is perfectly clear;

Better than int_t for the operation known as "unique type" IMHO.
But mpl uses int_t for other things as well. If all we're talking
about is usage _a_la_ MC++D, why not "unique_type?" I proposed
this in another thread, but no one seemed interested. Perhaps
it's a little too generic. unique_type<isPolymorphic> looks
a little strange. :)

> "type2type" is perhaps not as obvious, but it's a better name than
> anything else proposed so far.

dispatch_type? That's indicating a rather specific usage. I
kind of like type_wrapper myself. It's a kind of indirection.
type2type<...>::type is the "dereference" operation. Should
that somehow play into the name?


"Some little people have music in them, but Fats, he was all music,
  and you know how big he was."  --  James P. Johnson

Boost list run by bdawes at, gregod at, cpdaniel at, john at