Boost logo

Boost :

From: Eric Friedman (ebf_at_[hidden])
Date: 2001-11-29 17:22:06

*_wrapper seems like a step in the right direction for the reasons
Matthew articulated, but a "wrapper" connotes (to me at least) some kind
of functionality being added by the wrapper to the existing type --
which is certainly not what's happening.

So what about *_tag (type_tag, int_tag, bool_tag, ...)?

It's shorter, yes, but it also seems to better connote what it used for.

- Eric

-----Original Message-----
   Date: Thu, 29 Nov 2001 10:20:42 -0800
   From: Darin Adler <darin_at_[hidden]>
Subject: Re: Submission: typelist

On 11/29/01 10:15 AM, "Matthew Austern" <austern_at_[hidden]>

> For what it's worth, I like your *_wrapper names. I'm not sure if
> I can articulate a reason why I like them a bit better than Andrei's
> names, but I'll try.
> First the "2" in the name, for "to", isn't used anywhere
> in the standard. It seems like a slightly different style.
> Second, and this might expose a real philosophical difference
> (perhaps a misunderstanding on my part), Andrei's names are
> names of actions, not things. I realize it's possible to
> think of metaprogramming classes as higher-order functions,
> but I still feel slightly uncomfortable giving a class a
> name that connotes a function; I think of a class as something
> that is, not something that does.

I also prefer the *_wrapper names, for the same two reasons.

    -- Darin

Boost list run by bdawes at, gregod at, cpdaniel at, john at