Boost logo

Boost :

From: Mark Rodgers (mark.rodgers_at_[hidden])
Date: 2001-12-11 03:42:49

From: "Andrei Alexandrescu" <andrewalex_at_[hidden]>
> I agree. I'd be glad to enhance typelists. What I want to stay away from
> gratuitous changes. "You know, what used to be 'length' is now 'size'. I
> don't know exactly why."

Well you're faced with a name change anyway. What was Loki::Length has at
least got to become boost::loki::length.

It seems to me sensible to correct a mistake and call it size at the same
time. In the standard, the name for a function that returns the number of
elements in a list (or indeed any container) is spelled s-i-z-e.

I don't think it matters whether it is a std::list or a type list, they
should use the same name. IMHO you erred in using Length. Now is a good
time to fix it.

> I agree again... *but*. The implementation of typical typelist algorithms
> where the typelist user goes to find inspiration for their own algorithms.
> Look at the *simplest* mpl algorithm that does something on a typelist.
> And don't even get me started about error messages...

Yes this is a valuable debate to have, but not one that I feel we should
address yet. Let's give the MPL time to mature before we address its
merits relative to a simpler implementation. All I'm arguing for is to
avoid prejudicing that debate by first accepting something incompatible
with MPL. Change the interface of your submission to match MPL and I'd
be happy to vote for acceptance when it came to formal review.

It also certainly seems sensible for us to use boost::mpl as a namespace
for this stuff even if we don't ever end up accepting all of Aleksey's MPL.
We do need some sort of meta-programming library, and mpl is a better name
for it than a loki.


Boost list run by bdawes at, gregod at, cpdaniel at, john at