Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2001-12-17 12:17:42


From: "Jeremy Siek" <jsiek_at_[hidden]>
> On Mon, 17 Dec 2001, Peter Dimov wrote:
> > Only the users of nonconforming compilers/platforms will need to use the
> > macro. Nothing is uglified.
>
> That's not really true. Any developer that wants his or her code to be
> portable will need to uglify, which is (hopefully) all boost developers.

Most boost libraries are already uglified beyond recognition. ;-) Sad but
true. I'd expect libraries that use metaprogramming to be even uglier than
the norm, esp. if they target MSVC 6 or Borland 5.5.1.

> > Deciding between "works now" and "is the right thing" is difficult,
> > but we need to take into account that names we choose may well last
> > for five-ten years or more, long after the specific nonconformances
> > are addressed by the vendors.
>
> True in general, but in this case the difference between nil and null_type
> is so trivial that there is no real advantage in the long term either way.

Perhaps. I don't really care about the names. Call 'nil' 'fish' and 'pair'
'frog' if you like and this will not even slow me down. I've simply outlined
my opinion on how things should be named, and I can provide a rationale for
most names, if necessary.

My point here was that we should choose names based on their own merits.
Other concerns may be used as tie-breakers if nil and null_type are
considered equally good. I, personally, don't like the _type suffix since it
adds nothing.

BTW by the proposed naming convention nil should become ct_nil (if we regard
"nil" as a keyword.)

--
Peter Dimov
Multi Media Ltd.

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk