Boost logo

Boost :

From: Vesa Karvonen (vesa.karvonen_at_[hidden])
Date: 2001-12-20 07:32:08


If there are no objections to this, then I'd like to make the change. I'll
leave the old names there for now and document them as obsolete. For example:

    //! Obsolete. Use BOOST_PP_ADD().
    #define BOOST_PREPROCESSOR_ADD(X,Y) BOOST_PP_ADD(X,Y)

    //! Expands to the sum of X and Y.
    #define BOOST_PP_ADD(X,Y) BOOST_PP_ADD_I(0,X,Y)

This change would also reduce the library size by some ~17kb. Preprocessing
speed is only marginally faster.

From: "David Abrahams" <david.abrahams_at_[hidden]>
> I wouldn't oppose a transition to BOOST_PP...
> we could always hold onto the old names for a while for
> backwards-compatibility.

> From: "Douglas Gregor" <gregod_at_[hidden]>
> > On Tuesday 18 December 2001 06:47 am, you wrote:
> > > I think that a big part of the readability problem is caused by the 18
> > > character prefix:
> > >
> > > BOOST_PREPROCESSOR
> > > 123456789012345678
> >
> > I often wondered why we ended up choosing such a lengthy prefix, when
> > something shorter (i.e., BOOST_PP) would suffice. In fact, I think a
> shorter
> > prefix would be more readable in this case, because preprocessor
> > metaprogramming is very whitespace-sensitive, sometimes causing very long
> > lines to be required; the long prefix makes these lines REALLY long, and
> > hides the intent.
> >
> > Doug


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk