Boost logo

Boost :

From: Thomas Lien (tgunlien_at_[hidden])
Date: 2001-12-28 17:28:11


Some random questions about boost naming conventions:

1) I've noticed many member variables for boost
libraries end with an underscore. Is this a
defacto-standard? Should a standard care about such
things?

2)
while(true) {
  // ...
}

OR

while(true)
{
  // ...
}

3) Why do concepts have all the capitalization style
instead of underscore separated style
(DefaultComparable instead of default_comparable)?

=====
When he was six he believed that the moon overhead followed him, by nine he had deciphered the illusion trading magic for fact. No tradebacks. So this is what it's like to be an adult. If he only knew now what he knew then...- Pearl Jam

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk