From: Jens Maurer (Jens.Maurer_at_[hidden])
Date: 2002-01-01 15:32:13
> It's at:
> It is just a bunch of state-saving classes for I/O streams. The
> latest version moves the classes to the boost::io namespace.
This appears to be reasonable, since we may have a bunch of other
I/O stuff soon.
I think the classes are useful; I've often had the need to
temporarily switch the precision (or the fmtflags) and restore
the old value afterwards. Often, I don't do it in an
exception-safe way out of lazyness. These classes help me
I've had a quick look at the implementation. I'd really
like to see these macros go away. I believe they can be
replaced by templates that take (among other things)
member function pointers as value parameters.
I'd like to see this investigated.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk