Boost logo

Boost :

From: Gustavo Guerra (gustavobt_at_[hidden])
Date: 2002-01-21 17:13:00

From: "vesa_karvonen" <vesa_karvonen_at_h...>
> They would be shorter. Currently the _R postfix is reserved for a
> special use (see BOOST_PP_FOR() documentation), but it could be
> changed (but not to _D, because it is reserved for another purpose).
> If we want such short names, then I'd probably go for "foldl"
> and "foldr", because they are used in many functional languages.
> Unfortunately they are difficult to read. I'd go with the longer
> names.

Do they really conflict? Isn't _R just used in BOOST_PP_FOR_R?

> I think that these changes should not bring too many problems.
> Perhaps the biggest problem I see is that it might be difficult to
> find intuitive names for new PP macros at some point. On the other
> hand, I don't see much scope for extending the library in terms of
> new data structures, etc... At the moment, I think that adding more
> data structures would simply be futile.
> Of course, I'm not ignoring the problem that it may be a little bit
> more difficult to learn to use the data structures at first, because
> the prefixes do give some cognitive context.

Although I like short names, I think ommiting the type altogether might be
confusing. I suggest BOOST_PPL_xxx for lists and BOOST_PPT_xxx for tuples?
For consistency, you could rename others to BOOST_PPA_xxx(or BOOST_PPI_xxx)
for operations on aritmetic(or integer) types, BOOST_PPB_xxx for operations
that expect boolean values, and so on?

Gustavo Guerra

Boost list run by bdawes at, gregod at, cpdaniel at, john at