Boost logo

Boost :

From: Stewart, Robert (stewart_at_[hidden])
Date: 2002-01-23 14:49:16

From: Samuel Krempp [SMTP:krempp_at_[hidden]]
> On Tue, 2002-01-22 at 10:34, Yitzhak Sapir wrote:
> about 'format' not expliciting it is only output oriented, well, it's
> true the name is not as explicit as 'printf'.
> But it won't be a problem for later finding a name for a formatted input
> library, one can forge the name from 'parser', or the like.
> Even if input and output could share the same style of usage, the 2
> aspects should not be implemented in the same class, so the 2 classes
> would need distinct names.


> format / parse, or input, or reader, ..
> One thing I believe, is that the name 'format' fits ouput better than
> input, and that the Boost.Format library has the right to take it !

Why not simply "iformat" and "oformat?" This follows the istream/ostream
precedent. Clearly, at this time, we have only "oformat," but why not allow
for "iformat," should it come along?

Susquehanna International Group, LLP

Boost list run by bdawes at, gregod at, cpdaniel at, john at