Boost logo

Boost :

From: boost (boost_at_[hidden])
Date: 2002-01-25 02:21:13


On Thursday 24 January 2002 15:48, Jeremy Siek wrote:

> Sure it does. Isn't x * A really A^T * x. When you transpose a matrix, the

No, only x^T * A == ( A^T * x )^T, one shouldn't mix
x and x^T.

> That's better, but I'm not a big fan of "row_count". Someone could read it
> as the length of a row, instead of the number of rows. I think "num_rows"
> is better (and that is nice and consistent with the naming scheme in the
> BGL, which uses num_vertices and num_edge).

In my opinion size1() and size2() are fine.

Best wishes,

Boost list run by bdawes at, gregod at, cpdaniel at, john at