Boost logo

Boost :

From: Dylan Nicholson (dylan_nicholson_at_[hidden])
Date: 2002-03-20 17:59:38

 --- Beman Dawes <bdawes_at_[hidden]> wrote: > Attached (hopefully) is
Just one comment - stylistically, although having lots of different functions
with long descriptive names probably makes code a little easier to read, it
somehow looks inelegant and atypical. Also it makes it harder to find
documentation for specific function.
I would tend to coalesce functions with similar functionalities into the same
function name and add flags for specialised behavior.
create_missing_directories() stands out in particular - I would expect
create_directory to simply take a flag (defaulting to false) specifying whether
it should recursively create the necessary parent directories first (like the
Unix mkdir utility). Similarly with remove and the various forms you have.

What's the point of is_read_only? Surely this would be detected through

Dylan - Yahoo! Movies
- Vote for your nominees in our online Oscars pool.

Boost list run by bdawes at, gregod at, cpdaniel at, john at