Boost logo

Boost :

From: Jan Langer (jan_at_[hidden])
Date: 2002-03-22 09:37:14

On Wed, 20 Mar 2002, Beman Dawes wrote:
>Please remember that this header is only part of the picture; there will
>additional headers (dealing with paths, attributes/properties, and
>exceptions) in a complete filesystem library.
>Right now, the only documentation is supplied as comments in the header
>code. Once the header is stable, I'll move the specifications to an HTML
>There are a number of comments in the code which begin "TODO". These often
>represent uncertainties; I'd appreciate opinions on how to deal with these.
>There are a number of comments in the code which begin "Rationale" that try
>to explain why various decisions were made. Of course these are in the
>context of the design document:
>If you disagree with any of the decisions, I'd appreciate rationale for

great. i think its a good compromise of the various opinions. i would
prefer move instead of rename. especially the dir_entry and dir_iterator
things should fit to most needs.
in my opinion it is not that important if the convenience functions are
exactly the needed ones and nothing more. perhaps one has to write one
or two lines more (or extra function) to achieve a certain operation.
but everything can be expressed in terms of the basic operations.

>I have a Win32 implementation; once the header is stable perhaps someone
>else would like to contribute a POSIX implementation.

i have already parts of that. and it should not be very difficult since
the interface is stable. as soon as i have finished other things i will
continue this work.
as i see it, there is also no further need for the string_cast.


jan langer ... jan_at_[hidden]
"pi ist genau drei"

Boost list run by bdawes at, gregod at, cpdaniel at, john at