From: Jan Langer (jan_at_[hidden])
Date: 2002-03-26 15:20:48
On Tue, 26 Mar 2002, Beman Dawes wrote:
>Attached is an updated version of boost\filesystem\directory.hpp.
>It uses the options approach discussed previously.
>It seems to me to be a lot cleaner and more usable than the previous
>attempt, which relied on explicitly named functions.
- i am against directory_entry overloads. because they are only
sensible for the attribute like functions (is_... and exists). and
these functions can also be accessed by the real attribute system.
- is the is() function intended to replace is_...() or just an addition.
in either case i like it. but we should wait until we have determined
how the attribute access system works.
- i would replace the readonly-flag by writable and readable (and also
is_readonly by is_readable and is_writeable). this is much clearer.
- what does the prune option do? its value is the same as recurse (is
this intended) and shouldn't the comment be replaced by "operate only on
directory contents". please say a few more words on this.
- there is something wrong with the throw condition of create_directory.
perhaps it must be completely inverted.
- i am in favour of the first move posibility (not make directories if
needed) b/c i think a more restricted default behaviour if good.
- why should directory_entry be deep copied?
i think now its a easy interface which opens a quite large room of
possible operations. i like it :-)
-- jan langer ... jan_at_[hidden] "pi ist genau drei"
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk