Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2002-04-11 12:22:14

On Thursday 11 April 2002 12:39 pm, you wrote:
> > With a few using declarations it would be more readable:
> >
> > boost::signal<int, int, int, combiner_is<maximum<int> > > sig_max;
> >
> > This syntax is clearer to me; does it work for you as well?
> FWIW I like your original named parameters approach better.
> boost::signal<int, int, int>::combiner_is< maximum<int> >::type sig_max;

My only complaint against the original named parameters approach is that it
gets really obnoxious when one of the types is a template type. I really,
really hate:

  typename boost::signal<T, T, T>::template combiner_is< maximum<T> >::type

I'm not even sure where the 'typename' belongs in that mess...

> Also,
> typedef boost::signal<int, int, int> signal_type;
> typedef signal_type::combiner_is< maximum<int> >::type signal2_type;

I can't see any actual reason to do something like this, but maybe it's
useful. When would I want to adapt/override a combiner?


Boost list run by bdawes at, gregod at, cpdaniel at, john at