Boost logo

Boost :

From: Hamish Mackenzie (hamish_at_[hidden])
Date: 2002-04-14 11:51:23

I think a lot of confusion has resulted from people, including myself,
thinking that mpl::type_list and loki::type_list are (or should be) the
same thing. Both have advantages and disadvantages.

If mpl and loki are to be integrated it is loki::type_list and
mpl::list_node that need to be merged.

loki::type_list could be renamed to type_list_node.

Then mpl list_node could be split into type_list_node and value_list_node
(reducing the number of template args from 4 to 2).

This would leave us with
  mpl::type_list == loki::TYPE_LIST_NN
  mpl::type_list_node == loki::type_list_node

This will have some implications. Here are the ones I can see

* To use a mpl::type_list with a loki class you will have to use ::type
eg. mpl::type_list< int, float >::type
This problem should go away once template typedefs are available.

* To use other mpl containers with loki you will need to convert them (I
assume this is a common requirement with a simple solution).


Boost list run by bdawes at, gregod at, cpdaniel at, john at