Boost logo

Boost :

From: Kresimir Fresl (fresl_at_[hidden])
Date: 2002-04-17 02:13:09

Hi Joerg,

> So Toon convinced me, that the proposed
> extension is sufficent general to be even useful in the BLAS context ;-)


> The only change to the proposed matrix_view could concern the name: Toon
> mentioned, that Blitz++ uses the term 'cartesian product indirection' for
> this matrix view (sic!), and we also see some similarity to valarray's
> indirect_array. Therefore we agreed for the present to call the beast
> matrix_indirect.

Yes, I thought to propose (when the time comes) `indirect_something'
as a more descriptive name.

BTW, I hope that there will also be `vector_indirect' ;o)



Boost list run by bdawes at, gregod at, cpdaniel at, john at